Why can't I upload a profile photo?

Since I’m planning on trying to do a trip report next week, I figured it was finally time to upload a profile photo. But when I go to do it, while it looks like it initially saves:

And I click “save changes” and then “save changes” again on the preferences page - but it just shows me as a gray head after that. If I re-open this widget, my photo is gone and it shows the grey head instead. I’ve tried multiple times now, with different photos too. Nothing seems to take. Any ideas?

Also - I was originally trying to do this via a Mac, using a Chrome Browser. But I just tried from my iPhone, using the mobile safari browser and had the same issue.

I meant to see if there is anything about this on the software forum. I will check. I think a few liners had the same issue but it got fixed.


Actually, I think they could only get their Initial to post?

@len I am sorry to tag you but did the forum have a recent update?

I found this:

Allow uploaded avatars by trust level

Previously, admins could disable support for custom, uploaded user avatars, but this would impact all users on the site. The allow uploaded avatars site setting now supports trust levels, enabling a site to prevent lower trust level users from uploading avatars while allowing high trust level users.

@david, could this be why the avatars are blank?

Yeah, I can get my initial to post, if I switch it to the top option “System assigned profile picture”. That’s how it had been before I tried to upload a photo. Now I’ve got grey head.

If it helps, I think my current “trust” level on the forum is listed as “member” at least according to my badges. I’m not “basic” anymore (I mean, I am, but just not according to the forum backend :wink: )


I just seem to remember the trust levels for all of us being frozen at member. I don’t know if that is what is going on?

@Randall1028, how did you get it to post your R?

Trust level is bizarre given some of the members who have been impacted.

I don’t think it is a feature TP uses. Do you remember the first few days with the automatic titles?

1 Like

If it is the trust levels I wonder if we could change it for a day or two to allow everyone to fix their issues and they pin a warning?

1 Like

that was just the default. It was the the only option

1 Like

You were able to default to C?

Yeah, I was always able to go back to the C. My options (referencing that first photo) are either the default option 1 - which gives you a letter - or if you do option 2 or 3 it gives you grey head. The issue is that the image uploading isn’t sticking for some reason.

Which - based on what @Randall1028 said - I think he has the same options.

Yes, we all have the trust level “member”. If I am correct that the issue is that basic and member does not allow the avatars to be uploaded- then it could be an option none of us will have?

If you search this category of the forum for threads about “trust levels” you will find a few. Seven years ago when the forum was created, it was not a smooth roll out. I believe the trust levels are designed by the creator to allow users to do more and more on the forum? Skimming the threads just now it seems like some of us moved up to “leader” levels pretty quickly? I have no idea what tweaks were made to allow the forum to continue safely and what t weeks were made because the liner community lost their minds ( yes- I said it, and I am being nice).

1 Like

Running into this today as well.

That’s a good guess, but it does not look like our forum software has been updated recently, and the old, forum-wide setting that allows avatars is still enabled. In short, I can’t explain this behavior, and I’m curious whether it goes away after someone logs out and/or after a few days. Creating a Gravatar might be a good alternative.

Doesn’t look like it. I waited a couple days to see if the upload would “kick in” before posting, no dice. And then I just logged out and logged back in and then tried - no luck there either.

I did some Google research, and it sounds was a known issue, at least in certain environments in the past. I’ll notify the vendor that hosts our forum software.

There may not be a fix. One workaround would be to create and use a Gravatar.

Same problem happens when trying to use my gravatar.