Trouble inviting family to share on MDE


#1

I’ve sent DW an invitation to share on My Disney Experience, but when she tries to accept it keeps failing. It says (paraphrasing) “Sorry, we are having trouble finalizing your invitation…”, and asks me to resend my invitation or call a support phone number. Before I call, I thought I’d ask all you smart people! :slight_smile:

Has anyone seen this, and does anyone have advice? (SIAP, I did a few quick searches but didn’t see anything relevant.)


#2

Is she logging in through a browser? Is it Safari? I had to switch to Chrome.


#3

Interesting… We first tried between iPhones, using the WDW app. No dice. I tried from computers at home (I’m on a Mac/Safari, she’s on a PC/Chrome). Didn’t work there either. I’m starting to think it’s gonna take a phone call.

Obviously I’d like to be able to link her so we can both see photos/plans/etc. I’m kinda surprised I’m having this kind of trouble.


#4

One last thing- have you tried private in Safari and incognito in Chrome?


#5

I have had to make the call - in my case, it was for a child who had come of age (13) while attached to someone else, and was trying to establish his own MDE account and travel with me.

The CM on the phone was incredibly helpful, and took care of everything without concern. Rather than trying to troubleshoot yourself, I’d go ahead and pick up the phone. I think I was on for <15mins to get it all resolved.


#6

We had to make a call also – apparently since our friends had bought park tickets under their own MDE accounts it took another step? Anyhow the CM fixed it in two minutes, so it was totally worth the call.


#7

Thanks all. I did finally call them and like you both said…it was quick and easy. I apparently had another Disney World account from way back that I forgot about. I’m shocked, SHOCKED, that it was user error all along! :slight_smile: