Photopass Website-Can't seem to load


#1

So we just got back from our trip to WDW and I can't seem to load the Disney Photopass website. I can access photos through the My Disney App on my iPhone but when I log into disney website on the computer and then try to access photo pass, nothing. It's simply a white page, nothing loads. Any ideas on how to remedy this? Thanks!!


#2

Try to switch browsers and clear cookies. I also have had the best luck early in the morning or late at night. If more than one person is logged into the account, it can cause problems in this case. So make sure you are the only one logged in.


#3

Thank you! I will try those first two ideas right now (and didn't even think about late at night/early in morning to try). Thanks!


#4

I have that issue sometimes with Disney sites. I usually find "incognito" in chrome or "private" in safari will work.


#5

They have been having a lot of problems with it for the last week or so. They have posted a message on the download page (when you manage to get to it) apologising and saying that they will extend the time available for download because of the errors.


#6

I ended up downloading firefox to my mac to try and it worked. Now that may have been coincidence, because I then went back to Safari later in the evening and ta-dah! it worked like there hadn't ever been a problem. I think you're definitely all correct, especially with them having issues on the site here recently. Thank you all!