No steps on map in touring plan?

Hello! I made my touring plan and historically, I’ve been able to see the steps in the map after I optimize. But right now there is just a map of the park with no steps in it. Am I doing something wrong? Is this feature no longer available? Do I just not have access to it? Thank you

This has happened to some of us.

It seemed to fix itself after refreshing I think.

Or maybe make a small change and hit evaluate?

1 Like

Neither of those worked. I tried desktop vs mobile too. I’ll have to see if it’s my other plans too, or just AK

1 Like

Nope, it’s all my plans. This puts a colossal damper on “evaluate.” I can’t tell where to place steps myself if I don’t know where they are. I’ll keep playing with it. Thank you for the suggestions @bebe80 :heart:

Totally understand. If it persists, post on the thread below. It is reviewed by Len.


Oh thank you!!


It’s happening to me, too – but if I click “Print Plan,” I see the map layout we used to get, with numbered steps so I can see if there’s any unnecessary backtracking.

1 Like