Disney on my computer defaults to UK and I can't get it back to US!

Has this happened to anyone else? I’m getting frustrated. My MDE profile is correct and American and in the past I saw the regular US site, but now anytime I see a price or a phone number it’s Euros or Pounds and non American. Why?? Any ideas? There’s a little drop box in the left corner saying Show or Hide Disney UK but it doesn’t do anything. And my addresses in my address bar change to say en_GB after the regular address. This is only happening for my disney pages. :frowning:

If you view your ‘My Plans’ page on Chrome, you should see a small globe in the top part of the page, right next to the ‘Sign Out’ option. Click on it and select ‘North America’.


I had the same issue where it kept defaulting to the UK. I cleared out my browser history and cookies and the problem went away.


This has happened to me too! I’m in Australia but always use the US site and then for a few days last month everything defaulted to the UK site and everything in Euros. Got around some of this using google to search and then clicking the US link but it resolved itself in a few days. Not a scientific answer, I know :joy:. But I haven’t had the issue since. Hopefully reassuring to know it’s happened to others and it does fix itself?

I use safari on a Mac. I had that problem and clicking on the globe didn’t help (it would only show options in Europe). My husband fixed it for me and said it had something to do with location settings in the browser. That’s all I remember, but I can ask him for details tomorrow…

Thanks all! I’m also on a Mac but use chrome. I cleared my browsing history then logged back in and when I clicked on that globe, the option of US came up! It absolutely wasn’t there before. So it was a combination of suggestions that appear to hopefully have solved my problem! :grin:

1 Like

AND I had been having this problem last summer after a trip to the UK, but it was rolling along fine as I’m planning our December trip. Now I have cleared cookies and everything and it STILL wants to default me to the UK site. What on earth am I missing?

I had this issue as well after clicking on a package deal that was for EU/UK only. This fixed the issue for me. If you are using chrome in the address bar go to chrome://settings/siteData. Or just google how to delete site specific cookies and delete the disney cookies.Or just delete all your cookies.

This will remove the cookie storing your remembered location.