Desktop problems

When I go to MDE, I can only look at one catagory such as dining reservations. When ever I try to go to the next catagory, such as magic bands or friends&family I get a mesage that there has been a problem and to try again later. I try to logg in again but I get the same message. So in order to get back on MDE I have to wait until the next day and the same thing. I get to look at one catagory. This is not new, it has been doing this for months.
Anyone have sudgestions to fix this?

Did you call Disney? I had a problem where MDE kept kicking me off and it was a common problem fixed by clearing my history. I wouldn’t be surprised if they could help you.

Try clearing your cache.

1 Like

You can also try using incognito/private browsing. I frequently need to do this when using MDE

yes this

Tried that many times without success.

Just tried this and it works perfectly. I don’t know why I never tried this before.


Glad incognito worked. If you have some time, still call Disney.

I called with a Magic Band question the other day. The CM said my MDE account looked all wonky to her. I admitted I had been having some issue for months. She fixed it in 5 minutes.

I just figured it was some crappy Disney IT issue across the whole platform because of all the posts about MDE problems. But, it has run perfectly since then. Good luck.

A number of issues can be due to your browser holding onto bad settings in the session state data it holds to ‘enhance’ your browsing experience. On way to clear this is to shut your browser down completely, or use a different browser. If you are using an Apple or Android product it is not always clear whether the browser has been shut down or if it has just gone into hibernation/standby mode so using a different browser can get around the issue.

Other issues can be due to data being odd at the Disney end and it is likely that only they can fix things. In order to troubleshoot an issue I would suggest trying to close the browser down completely and going in again. If that does not resolve things try a different browser. If that fails turn your device of and then on. After doing that you have established that the issue is not at you end and is therefore something Disney should be able to fix.

Note I work in IT support and development and have seen this type of support request a bit - no, I do not work for Disney but a Government.


I tried Google chrome and it works perfectly. Thanks for your input. I think it’s time to switch to Chrome. I have found lately that my current browser is getting out dated and doesn’t support a lot of things.

Which browser are you having trouble with?

Google with internet explorer.

I tend to use Edge and Firefox