WDW Droid Reservation...So over it

When the reservation opened for building a droid on August 7th, I was super excited. I was on different devices all day, well more than half the day, trying to get a reservation. Every single time I get to confirm, I got the message, “Something went wrong. Please try again.” I’ve followed people with similar issues on the Forum and Lines and tried their suggestions… different devices, different search engines, incognito… I’ve used different family members’ accounts and different credit cards. I think I have done it all. I was looking for December 18th.

I have been trying for the last 10 days and I still get the same message. I’ve called Disney and CM says I must reserve online. Really! I got Oga on August 7th but not the lightsaber or the droid.

Others have gotten through, but not me. As the days wore on and frustration set in, my logical side kicked in and said, “For $100+, the droid doesn’t wash dishes, do laundry, or clean toilets! It will look cute on the shelf collecting dust!”

I’m done trying unless someone can draw me back into the bubble for the cute droid.

1 Like

I just went on MDE and there is availability on the Droid Depot site on Dec 18

try this link:


1 Like

Set up a fresh MDE account.

My personal MDE account is useless for anything other that FPPs and ADRs. It just won’t cooperate at all. Ever. Ever. Ever.

I’ve complained multiple times. Once they gave me an extra anytime FPP for each day of my stay. Another time they gave me $50. But they can’t fix it.

So I set one up for my dog. He had no problem getting a Savi’s Workshop booking. He put my name down as the participant. And he used my credit card.


Thanks but I get the same error message.

You need an account that’s not linked to a hotel reservation.

It might be something to do with your browser – it has not happened to me but I have seen others comment on that.

Calling @OBNurseNH and @PrincipalTinker who may know how to fix this!

Mine is linked to my reservation so I don’t think that is it.


Try later and report. But then it would just be one person unless one of us sets up a dummy account. Then, we can get two people in. The dog isn’t going to go. He’d rather sleep.

1 Like

I’ve used Chrome, Safari, and Internet Explorer.

Yup. It worked.

Same with mine. He’s shown remarkably little interest in SWGE.


When you get to the part of the reservation where you have to say who’s participating, you just type in names. It’s not a drop down list or anything. This is why Matt can use his dog’s account to make a reservation for himself. This is why I used my sister-in-law’s account (she’s not coming with us) to make a reservation for my kids.

1 Like

Have you tried incognito or private browsers?


I was able to get a helpful cast member on the phone just now make droid reservations for me. For some reason when I call, I never get the free fastpass. Maybe I’m not irate enough. However, they stopped pretending that they couldn’t make the reservation over the phone when I explained the errors on the website and the fact that I had called last week about the same issue.


Wow! I will call again… Thanks!

Go incognito

I think the incognito mode suggestion was already attempted prior to the original post based on this.

Now, I was experiencing issues (not the same issue), and found that I would see the problem even in Private browsing in Firefox, but if I used incognito on Chrome it worked. But that was a for something else entirely related to MDE.

that is wonderful!

I have not a clue what this is, but fortunately MDE does not seem to treat me with the unkindness it treats other Liners…

I can never get passholder information unless I use private in safari .