Online check in

Just realized that I didn’t do online check in yet (arrive in 33 days) so I went to MDE to do it and it shows my reservation and there’s a place to click “check in online” but when I click that link I get “sorry…we can’t find your reservation”. Tried on phone app, full site via phone Web browser and even on my desktop. Any ideas???

I have always done hotel at 10 day.
ADR at 180 and FP at 60

Might be a glitch in the system - like that’s never happened before.:smiley:

I would try again tomorrow. If it’s still showing that, I’d call.

Same thing happened to me tonight while trying to check-in. I’m going to try again tomorrow.

I too forgot to do online check in. Log out & log back in to see if it helps!

Did you try:

Sometimes this works when the other links don’t

The online checkin system has been glitchy for months. I agree with the others above… try waiting a day, logging out and logging back in. If it still doesn’t work I would probably call just to make sure you reservation is all set.

That link works but there’s no place to put my room request. I mean, there’s a place that says “Add room request” but when I click it this pops up:

And the text in that box is permanent. It won’t let me replace it with my request. Gah!!

So I can do my online check in by phone? Who do I call for that?

Can I just do it without my request and fax my request in later?

I wouldn’t risk it.

I would call now, and fax later. The resort doesn’t get your info until about 5 days before you arrive, but any requests can be noted on your reservation now.

Up you are staying FQ? There was one time at PO r that I did not get any choices at online check in time because of the type of room I had.

We are staying at FQ. We just have a garden view…I wonder if it’s because we booked via CM discount?

Where can I go to get the fax number? My choice is limited to “ground floor/closest to transportation”, etc. The choices are checkboxes with no text box.

Try this: Resort Fax Numbers or Email Addresses For Room Requests


your not getting choices b/c FQ does not have any loaded into the online check in system. that’s not a glitch.

So should I fax/call? WWPGD? <-- (what would pirate girl do) :wink: