MDE not opening

Anyone else having difficulty opening the app? Specifically the tip board?

Mine has been “Adding a few more magical touches” for hours

No issue here. Sign all the way out and back in?

No problem here. I can’t actually see the tip board since I’m in the U.K. but it is opening to tell me I can’t see it.

Mine prompted me to sign in and gave me some difficulty with that but then opened as it normally does and allowed me to access the tip board.

Oh but now I changed park and I’m stuck in the magical touches void.

Gotta love Disney IT!

Glad I’m just playin right now. I’d be livid if I was there and this happened

1 Like

Oh yeah. That’d be a fun experience

Can’t sign out or do anything else on the app.
I could turn my phone off and on again but that’s about it.

1 Like

My favorite was that the park that defaulted as my tip board for the day was always the park I had an APR for the day before. Then sometimes “change park” would freeze.

1 Like

I just tried. First time I opened it, the app crashed. But that is nothing new…it has been doing that pretty much since they updated it for Genie+. But after restarting, it is working for me. I also tried changing parks.

1 Like

I was playing with it and it defaulted to HS. It allowed me to pick attractions. But then when I switched parks I could not pick and had to see the whole list. And it wasn’t related to availability because I checked that. It was just being a bitch

Is HS your next park that you have set with APRs?

Nope. That’d be Epcot

Well then it’s just disney tech being disney tech… which unfortunately, is the norm now. :woman_shrugging:t2:


It’s a good thing a major component of their guest experience and crowd management doesn’t rely on that then!

Oh, wait…


[Cue the Cat]

1 Like