MDE issues

My MDE today has decided that I am logging in from Europe (would that were true) and I cannot fix it. I have cleared the cookies in my browser, re-started my computer multiple times, and still it won’t reset. It directs me to the “en-eu” gateway for the site and is quoting me resort prices in Euros.

I remember seeing others reporting this problem but I don’t remember the fixes recommended. Does anyone know how to fix this?

Or, I could just move to Europe, I suppose.

At the top of the page towards the right, is there is a little blue globe with “Europe (English)” next to it?

Click on the globe and switch to whichever you should be on, US, Canada, UK and Ireland …

Yes, but when I do that my browser goes into an endless loop of trying to load the MDE page and failing.

Website or app?

I always go onto the website, change the icon and then log onto MDE. Sometimes I find I have to change it again when I log on, but usually it keeps what I set it to.

This is ringing a bell but I can’t remember what people did before. Sorry. :frowning:

1 Like

Thank you – I will keep at it!!!

Solved!!! The trick was to click on the icon BEFORE I was logged in – your message clarified that and it worked-- thx!


BEWARE: Any reservations you made or modified while in “Europe” will not be for the the date you desired! This is because of the transposition of the Day and Month between the two formats.


I have no idea why but this has happened to me multiple times in the past six months or so. No idea why it shifts to UK.

1 Like

Disney needs some new web developers. Thankfully I’ve not had your particular problem but their website is unusable in some cases and very unreliable other times. Page will fail to load and then work after a refresh. There are pop up screens you can’t scroll to the bottom of to get to the buttons. Fast Pass page shows everything correctly but the main My Plans page shows them wrong . That one cause some anxiety for minute. I have to login in constantly despite just logging in minutes earlier on another tab within same browser. Modifiying guests on an ADR works from app but not laptop. I could go on and on. Its like they have no one testing the site.


I just had to call Disney IT. Magic band page was throwing a permission denied error. I was on Chrome. They had me clear Cookies and other site info as well as Cached images and files and choose the option for ‘All Time’ at the top. That fixed my error and thought it might help others.

1 Like