I’m still using the forums on my iPhone 5s using safari.

Ads are still appearing even though I’m logged on and am a subscriber.

Also, despite having my cookies set to accept everything, I still have to log in again every so often. Any reason why this is happening. It’s not a huge deal, but it’s quite annoying.

It would be nice if ‘latest’ was clickable from within a thread, instead of having to clock through the main page between a thread and ‘latest.’


I see the same issue with “latest” showing no threads when I click it, so have to hit refresh each time after clicking. Safari on iPad Air.

I also read community guidelines many times, but no badge granted.

In the community guidelines it says that this is a searchable public forum… @len can you comment on that? The anonymity of lines is half the reason I like it. I don’t want my responses/chats/info publicly viewable…

@Mr_Itty and @NotThatKevinSmith Do either of you have thoughts on this? I am REALLY surprised by this. It really IS just like disboards…


I’ve figured it out. I had to clear cookies and data for Safari on my phone. I suggest updating the css so that the header (shown below) doesn’t shift off the screen on a mobile device when someone clicks on “desktop view”. It was so far over to the right that on my iPhone I couldn’t access the dropdown menu to revert back to mobile view.


Fantastic sleuthing @DadHatter!! Thanks for the tip too as I was stuck yesterday in desktop view. Somehow it reverted back to mobile today, but I couldn’t figure out how. Thanks!!

1 Like

Same issue here with clicking on latest. I have to refresh every single time because I get the notice that says there are no recent posts. Both on Safari in iPhone & on Chrome on PC.

“Un-pinning” a post only seems to partially work. I unpinned the BoG FP+ thread. It no longer shows up at the top of “latest” for me, but it still shows up as the top post of the default Categories view.

I tried to access the new forums on my iphone 4s again a little while ago, 3:13 ESt to be exact. It is still loading and spinning minutes later. Why does it need to do that and why is it killing my battery so quickly? What is it trying to load when I am not touching the phone?

I have an iPhone 4S also and it doesn’t load. And I can only get latest if I use @daybreaker link. Just clicking latest results in a there are no latest message.

Just so you’re aware on my galaxy s4 the site itself loads and works great, however, I can’t tag anyone because the auto complete window doesn’t load. The same issue is happening with the emote window after typing the : symbol. I tried it on both the system browser and in chrome.

When I click on Latest, the proper screen shows up but if I want the current info, I have to hit the refresh button. It always defaults to the same screen when I click on latest.

Ok, I have discovered I have to hit the refresh button regardless of what screen I am on. I think my browser is storing a particular “page” for each page if that makes any sense. Once I am on the page I want, I have to hit the refresh button for it to display the correct data. This is from my desktop. Windows 7 Home Premium. The latest version of IE (IE11). Haven’t tried it on Chrome yet but I will.

It works really well from chrome. Not sure about ie.

This sounds like a javascript issue. Does your browser have any specific settings regarding javascript turned on or off?

I can check…Not sure. Maybe it’s a phone wide setting.

Could that also be the reason that when I click on “Latest” from that little icon that looks like an equal sign with an extra line at the top of the page it will give me the message “no recent posts”? I’d really like to fix it, especially for me phone, because it makes it very cumbersome to use and definitely increases the data/battery usage to refresh constantly.

Just checked. JavaScript is turned on.

Its possible. The forum is a javascript application, so if you have any security settings or plugins that might be restricting it, it could be an issue.